Flyspray - The bug killer!

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend/Core
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 0.9.9-devel
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by Mark Walling - 08.12.2006
Last edited by Cristian Rodríguez R. - 08.12.2006

FS#1142 - error when posting comments

i have 2 installs of flyspray running. one is rev900 on IIS, and one is rev901 on apache 1.3. both are getting a similar error. when adding comments, IIS returns

CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers.

Apache, when doing the same thing (using firefox as my browser from home) attempts to download index.php (i never actually downloaded it to see what it contained). When accessing my apache from behind my work firewall, the firewall spits back a 'tcp_error' page.

To test if it was just me or not, i tried posting a comment to task 3 on this bug tracker, and got the following error:

Query {INSERT INTO `flyspray_notification_recipients` (notify_method, message_id, notify_address) VALUES (?, ?, ?)} with params {j,,jcollins@jabber.asgardsrealm.net} Failed! ()

i read the mailing list if you need to reach me

Closed by  Cristian Rodríguez R.
08.12.2006 23:32
Reason for closing:  Duplicate
Additional comments about closing:  

Duplicated of #1140

adding a test comment to make sure i am not crazy

hmm, it worked that time

here is the only thing i could find:

*** glibc detected *** double free or corruption (!prev): 0x0844f888 ***
[Sun Dec 10 11:44:30 2006] [notice] child pid 8227 exit signal Aborted (6)

there is one for each time we tried to reporduce that error, with a slightly different memory location.

i don’t think its a system specific error though, because my IIS box (which i do not have logs on (shared $4/mo hosting)) seems to be doing the same thing (application misbehaving ~~ php crashing???)

Admin

I have no idea how we could make PHP crash... -_-

PHP bug, not a flyspray problem.. Mark what PHP version are youy using, can u show phpinfo please.

apache


thanks mark, I’ll attempt to reproduce this on my apache + php 4.4, but anyway.. not a flyspray issue,. but a bug in PHP :-D

My only suggestion is to get rid of PHP4 ASAP ;-)

upgrading to php5 is on the todo list, but that list is pretty long.

i don’t have the option of upgrading the IIS/php4 server though.

if you want ssh to my box so you can poke at mine, i can set that up.

you have other problem in the IIS server though.. according to automated version checking tools, current flyspray 0.9.9 branch requires PHP 4.3.9 to run, and your IIS box has 4.3.8 :-P

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing