Flyspray - The bug killer!

  • Status Closed
  • Percent Complete
    100%
  • Task Type Feature Request
  • Category Backend/Core
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version 0.9.9.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by Nick - 06.04.2007
Last edited by Florian Schmitz - 06.04.2007

FS#1234 - Parse Descriptions With Dokuwiki Markup In RSS Feeds

Currently, for task descriptions, the RSS feeds show the plain text pulled directly from the database. This means that the description of each task in the RSS feeds is littered with Dokuwiki markup, assuming the Dokuwiki plug-in is enabled and the user styled their description.

I would like to see the Dokuwiki engine parse its markup and generate proper HTML for the RSS feeds, instead of just on the task page. It would enable users with RSS readers to see the task descriptions how the creators intended, without having to visit the site.

Closed by  Florian Schmitz
06.04.2007 07:26
Reason for closing:  Not a bug
Admin
Florian Schmitz commented on 06.04.2007 07:25

This is not quite true. Both RSS1 and Atom feeds have HTML “encoded” text (check the source if you don’t believe me). It’s up to your client whether or not it prefers HTML over plain text. RSS2 will never include HTML.

Nick commented on 06.04.2007 08:13

Why will RSS2 feeds never include HTML? The specification supports it, it just has to be encoded properly (which already occurs for the RSS1 and Atom feeds, as you pointed out). Many RSS2 feeds I subscribe to use HTML extensively, so it is a pretty common occurrence.

Also, I did not report this as a bug (just for reference).

Admin
Florian Schmitz commented on 06.04.2007 08:24

If we to that, there is no plain text alternative. Also, not every client likes HTML inside these elements.

Nick commented on 06.04.2007 08:37

It seems to me that if an RSS2 reader cannot handle HTML ... well, it’s time to update or change readers. I mean, why would high traffic sites include extensive use of HTML in their RSS2 feeds if a meaningful amount of readers would fail to render the content properly?

Users need to update their software sometime and I doubt any feed reader in active development, even maintenance development, in 2007 is going to lack support for HTML in feeds.

Admin
Florian Schmitz commented on 06.04.2007 10:12

Just use the RSS1 or Atom feed.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing