Flyspray - The bug killer!

Attached to Project: Flyspray - The bug killer!
Opened by simon Whittaker - 21.05.2008
Last edited by Psychokiller1888 - 22.03.2015

FS#1487 - LDAP(Active Directory) Authentication

I have done a very quick bit of work to bring ldap (through active directory) authentication to flyspray for our implementation in the office. I hope it will be of use to others. There is a readme.txt inside talking through the process and the patch to apply. My plan is to expand on this and make it part of the setup process but this will take a bit longer.

This task has the following sub-task
ID Project Summary Priority Severity Assigned To Progress
2209 Flyspray - The bug killer! FS#2209 - TLS support for LDAP Very Low Medium
0%
Tomasz Broniewski commented on 20.05.2011 13:02

simon, Great job!!!

Regards
Bronek

Sebastian Struß commented on 06.01.2014 11:21

is there a port for the current master? seems there has been some refactoring in the code...

Sebastian Struß commented on 06.01.2014 11:59

just did it, 3 of 4 chunks reject, but if you manually apply it, it works great (i am using 009e01aba031eafacde1ece6d5173a86d63e9fd4)

Ethan Zonca commented on 18.08.2014 15:02

I manually applied the patch against 0.9.9.7 and created a new patch from the result. The patchcan be found in the tarball below (apply with -p3):
https://aur.archlinux.org/packages/fl/flyspray-ldap/flyspray-ldap.tar.gz

If you use Arch Linux, I created an AUR package that installs patched version of Flyspray with LDAP support.
The PKGBUILD is a bit rough right now and configuration is still in class.flyspray.php, but it works.

https://aur.archlinux.org/packages/flyspray-ldap/

Project Manager
Psychokiller1888 commented on 07.03.2015 11:13

That's definitly a must, will be implemented!

Soltanici Ilie commented on 19.03.2015 13:39

Today i tested the long awaited alpha version 1.0 - and Active Directory authentication are not included, add it please...

Project Manager
Psychokiller1888 commented on 19.03.2015 13:43

As marked in this feature request, it's planned for 2.0. Will maybe be available for 1.1, but not for 1.0 for sure.

Project Manager
peterdd commented on 20.03.2015 05:58

Mmh, it seems that patch for 0.9.9.7 only uses php builtin ldap functions, so no need for extra adodb-ldap-inc.php loading here???

Added some code to github for further dev.

Dat Nguyen commented on 27.09.2016 04:37

Sorry but I do not understand this step "2/ apply the ldapauth.patch to your includes/fclass.flyspray.php and set the variables accordingly"
Pls give more details of this step
Tks

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing