• Status Closed
  • Percent Complete
  • Task Type Bug Report
  • Category Notifications → Email
  • Assigned To No-one
  • Operating System Windows XP
  • Severity Very Low
  • Priority Very Low
  • Reported Version 1.0 devel (github master)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray
Opened by MJLaine - 07.06.2012
Last edited by Psychokiller1888 - 06.03.2015

FS#1744 - Error "Connection could not be established" after upgrading from to

Please first excuse my poor english.

This message is for information only.

I upgraded from to, following this instructions :

  Create a backup of your files and database
  Remove all files except the attachments directory and flyspray.conf.php
  Copy the new files to the Flyspray directory
  make sure flyspray.conf.php is writeable by the webserver.
  Run the upgrader at http://yourflyspray/setup/upgrade.php

Everything was ok, until I tried to close a task.
After choosing the closing reason and pressing the "Clore la tache" (my flysprays's in french) button ,I had this error:

"Completely unexpected exception : Connection could not be established whith host [Connection refused #111] This should never happend, please inform Flyspray Developers."

When I tried again, It worked : no more error message.
I suppose it was a problem with my hosting ; but as the error message says "please inform", i felt i had to report !

The task blocks this from closing
ID Project Summary Priority Severity Assigned To Progress
1849 Flyspray FS#1849 - Installer Overhaul Low High
Closed by  Psychokiller1888
06.03.2015 21:29
Reason for closing:  Not a bug
Additional comments about closing:  

Well not a bug in the way that your smtp server was maybe not set correctly. We are aware that email errors need better handling

Got this one too, but already in the Whenever I've made changes to issues, the message appeared. Found this issue on google, where Swift Mailer is mentioned. After clearing out all information about SMTP mailer the problem is gone. Maybe some wrong settings prevented it from working.


Available keyboard shortcuts


Task Details

Task Editing