Flyspray - The bug killer!

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend/Core
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 1.0 devel (github master)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by Allo - 13.08.2012
Last edited by Jordan Mendler - 16.01.2013

FS#1762 - Edit Details and add a Comment Function lost in 0.9.9.7?

In 0.9.9.6 you could edit the Details and add a comment, so the comment had attached the information which fields were changes. In 0.9.9.7 this function seems lost, even when the attached information on old bugs still is visible as it should. But when editing bugs now, there is no "add comment" button anymore.

Closed by  Jordan Mendler
16.01.2013 23:44
Reason for closing:  Won't fix
Additional comments about closing:  

I don't think this is a big issue. While editing a task you should not need to add comments. Can do it separately. Let me know if you disagree

Allo commented on 17.01.2013 06:30

I think you did not see what function i meant. Its not about just adding a text-comment, but when i changed some field of the bug (summary, assignees, title, due date, etc.) there was an option to add a comment the same time, which gets some grey text at the beginning, which looked like this:

— Status: New →Confirmed
Due Date: None → 2013-01-30

I changed the Bug to confirmed and hope to have it completed until end of january

this was a nice feature, because you could see the context of a comment added this way.

Allo commented on 17.01.2013 06:32

sorry, flyspray ate the first newline after —.

and the text before the paragraph was inserted automatically and displayed grey.

Project Manager

I think Allo made a valid point.

The quick edit thing on details.view is not 'faster' than normal edit. Same amount of mouse clicks for one change, even more mouse clicks for multiple changes. I would even remove that, only keep the one click actions like 'vote for this task'.

And the possibility to write an optional comment when editing the full task is better then just having the history without context. (and which not everybody is able to see)

And one more thing with quickedit: It sends everytime a notification and a history log on each quickedit.
On the edit details form the user does normally all needed changes and saves resulting in only one notification sending.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing