Flyspray - The bug killer!

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend/Core
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Low
  • Reported Version 1.0 devel (github master)
  • Due in Version 1.1 devel
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by Steven Tredinnick - 26.02.2013
Last edited by peterdd - 19.09.2015

FS#1835 - Upgrade to 1.0 requires dokuwiki syntax vs. free text/html handled

As a result of adding CKEditor we now need to nicely handle previous installs data where dokuwiki syntax is still in situ.

To be completed in line with the upgrade process which also requires work.

Edit 2015-03-11 peterdd: Dokuwiki plugin will probably still be the default syntax plugin for FS 1.0. CKeditor with free HTML input adds too many security issues which weren’t not enough considered before. So we think Dokuwiki as the default is the better option for the release of 1.0.

Older installs of Flyspray use dokuwiki format.
Peoples who just used the later dev versions (after 0.9.9.7) of Flyspray used ckeditor/html as text format.

So the Flyspray userbase consists of 2 different content formats. We plan to provide automatic conversion options when doing upgrades of existing installations.

The task blocks this from closing
ID Project Summary Priority Severity Assigned To Progress
1849 Flyspray - The bug killer! FS#1849 - Installer Overhaul Low High
50%
Closed by  peterdd
19.09.2015 04:51
Reason for closing:  Fixed in devel
Additional comments about closing:  

A conversion of dokuwiki to html/ckeditor is not needed anymore.

We keep supporting dokuwiki and even recommend it as default again for FS1.0

User can decide on install if he wants dokuwiki or fullhtml/ckeditor.

Upgrades just keep the settings that exists of the old installation.

In rare cases, a conversion from text to html is offered as option to the user who does the upgrade. But it's just an option.

Anton commented on 26.03.2014 19:49

Hello help me please
When i view comment , i see this notice

Notice: Undefined index: tasklist_type in /homeweb/*/public_html/includes/class.tpl.php(128) :
eval()'d code on line 85
Notice: Undefined index: tasklist_type in /home
web/*/public_html/includes/class.tpl.php(128) :
eval()'d code on line 90

Im used PHP 5.4
How to fix this ?

Project Manager
peterdd commented on 11.03.2015 02:28

reopened because problem wasn't solved and a requirement for 1.0.

Jouni Ahto commented on 11.03.2015 13:23

Just a note: We seem to be using CKEditor 4.0.1.1 and it was added to the codebase on 26.2.2013. The current version is 4.4.7 released on 27.1.2015. I could try to update it on a separate branch and see what will happen.

Project Manager
peterdd commented on 11.03.2015 17:30

Good idea, jahto.

If you are updating the ckeditor, please check which feature are really needed for Flyspray. The less feature/plugins we install/activate, the less the pain.
If I remember well, you can choose which features you want when downloading ckeditor.

Jouni Ahto commented on 11.03.2015 17:55

My guess, it's this line I found from not yet updated version in js/ckeditor/build-config.js: preset: 'standard'. So that't what we'll must go with, no time anymore to find if we could strip something out. Anyway, updating it works and seems quite safe thing to do, although the pull request is quite big.

Project Manager
peterdd commented on 19.09.2015 04:40

We now let the user the choice if he wants dokuwiki syntax of full html.

For new installs now dokuwiki syntax is preselected and recommended if the user is unsure what the better is.

So we can remove the blocking for a FS1.0 release and can move the final solution of this task to FS1.1.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing