Flyspray - The bug killer!

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend/Core
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version 1.0 alpha1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by Ivan Zhirkov - 04.09.2015
Last edited by peterdd - 17.10.2015

FS#2043 - after enter confirmation code from email i see SQL query in browser

version flyspray-1.0.alpha2

1. signup
2. receive email with confirmation code and link
3. go to page /task/index.php?do=register&magic_url=8a043cb5bf264758f1664c7db207a2c1
4. enter code confirmation and submit
5. see only this SQL query in browser :)

Query {INSERT INTO `flyspray_searches` (user_id, name, search_string, time)
                         VALUES (?, ?, ?, ?)} with params {2,Задачи, которые я отслеживаю,a:16:{s:12:"only_watched";s:1:"1";s:6:"string";N;s:4:"type";a:1:{i:0;s:0:"";}s:3:"sev";a:1:{i:0;s:0:"";}s:3:"due";a:1:{i:0;s:0:"";}s:3:"dev";N;s:3:"cat";a:1:{i:0;s:0:"";}s:6:"status";a:1:{i:0;s:4:"open";}s:5:"order";N;s:4:"sort";N;s:7:"percent";a:1:{i:0;s:0:"";}s:6:"opened";N;s:18:"search_in_comments";N;s:14:"search_for_all";N;s:8:"reported";a:1:{i:0;s:0:"";}s:12:"only_primary";N;},1441343882} Failed! (Incorrect string value: '\xD0\x97\xD0\xB0\xD0\xB4...' for column 'name' at row 1)
Closed by  peterdd
17.10.2015 05:16
Reason for closing:  Not a bug
Additional comments about closing:  

problem has its root in charset problem, which is handled by FS#2044

Ivan Zhirkov commented on 04.09.2015 10:49

Ok.

now i understand where problem:

Process of installing bug tracker not asking collation and charset for creating tables and make tables by default charser

need add to install request about charset of table creating

Ivan Zhirkov commented on 04.09.2015 11:11

in version 0.9.9.7 have same problem

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing