Flyspray

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Notifications → Email
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version 0.9.9.7
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 1
  • Private
Attached to Project: Flyspray
Opened by cabfever - 26.09.2015
Last edited by peterdd - 27.10.2015

FS#2061 - Mail notification is not always sent

Hello over there!

First of all: Thanks for your awesome simple designed bug tracker software. I was looking for something like this for a long time and finally found it.

Now to the issue:
I entered my SMTP details under “Admin Toolbox” → “Preferences” → “Notifications” But so far, I got only 1 mail of a changed task where I should at least get 3 (because someone commented on my created tasks and changed the status etc).

I tested it with a 2nd account and commented on a task I watch and I did not receive the mail.

So, is this a known issue that notifications aren’t sent always?

Closed by  peterdd
27.10.2015 08:53
Reason for closing:  Can't reproduce
Additional comments about closing:  

seems to be fixed by upgrading to github master

Project Manager

Could you please test if this is solved with the current github master.zip?

https://github.com/Flyspray/flyspray

How do I update my flyspray installation without breaking it?

Ah, on the "Download" section of the documentation. Did not expect that :)

Warning: require(/var/www/html/flyspray/vendor/autoload.php): failed to open stream: No such file or directory in /var/www/html/flyspray/setup/upgrade.php on line 45 Fatal error: require(): Failed opening required '/var/www/html/flyspray/vendor/autoload.php' (include_path='/var/www/html/flyspray/includes/external:.:/usr/share/php:/usr/share/pear') in /var/www/html/flyspray/setup/upgrade.php on line 45

There was no vendor folder in my 0.9.9.7 installtion.

Project Manager

Could you call /setup/ instead of /setup/upgrade.php?

This checks for missing vendor/ and guides you through installing missing components and also assists in upgrade if an existing flyspray.conf.php is found.

I corrected it a bit on Readme.md but sure it should be updated on the 'download' page.

Okay, it seems to work now with the git master version. But is the master also considered stable?

Admin

For my personal view it is "ok". I run my normal and test installs with github master und I keep an eye on that the upgrader works regardless of upgrading from 0.9.9.7 to github master or a FS1.0 alpha or this years github master to latest github master.

Database structure is finished for next release. (FS1.0 beta)

Feature freeze is now and only small fixes in the user interface now.
Only changes to github master allowed that do not break anything.

Project Manager

Is the original problem solved so i can close this task?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing