Flyspray - The bug killer!

  • Status Planned
  • Percent Complete
    10%
  • Task Type Bug Report
  • Category Installer and Upgrader
  • Assigned To No-one
  • Operating System Linux
  • Severity Medium
  • Priority Medium
  • Reported Version 1.0-rc
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by xiurobert - 24.03.2016
Last edited by peterdd - 04.04.2016

FS#2111 - Upon trying to install flyspray release, setup says I'm trying to install development version

When I tried to install a instance of flyspray that is a release, I am greeted with a screen that says that I am trying to install a development version of flyspray. Due to me using shared hosting, I am unable to run any composer commands.

My version of flyspray was downloaded from flyspray.org, so why would this be happening? Thanks

Project Manager
peterdd commented on 04.04.2016 11:12

Updated http://www.flyspray.org/docs/download/ with a release for PHP5.2 and PHP5.3 that also contains 3rd party libs.

php -v
PHP 5.3.3 (cli) (built: Jul  9 2015 17:39:00)

Steps to build flyspray-1.0-rc_php533.tgz from github Flyspray 1.0 RC release v1.0-rc.zip for PHP5.3 including required 3rd party libraries:

unzip v1.0-rc.zip 
cd flyspray-1.0-rc
curl -sS https://getcomposer.org/installer | php
php composer.phar install
mv vendor/league/oauth2-client/src/Grant/AuthorizationCode.php vendor/league/oauth2-client/src/Grant/Authorizationcode.php
cd .. 
tar czf flyspray-1.0-rc_php533.tgz flyspray-1.0-rc

Notes: I ignored some warnings about composer pubkey checks, added a quick fix for making oauth2-client v0.3 working on PHP5.3 . For PHP5.2 the oauth2 feature is not possible. The oauth2-client 0.3 version is the last version that can work with php5.3.

xiurobert commented on 05.06.2016 03:12

Would it be possible if you packaged a compiled version of flyspray and upload it to GitHub releases?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing