Flyspray - The bug killer!

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend/Core
  • Assigned To No-one
  • Operating System Linux
  • Severity High
  • Priority Very Low
  • Reported Version 1.0-rc
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by Alex - 01.08.2016
Last edited by peterdd - 03.08.2016

FS#2187 - Problem with HTTPS Reverse Proxy

Hi,

im using a HTTPs reverse proxy in my system.
To access my flyspray i connecting via HTTPs to the reverse proxy and the reverse proxy connecting via HTTP to flyspray.

It seems that you are using static links with “http://” because chrome blocks several resources.

Here’s one example:
Mixed Content: The page at ‘https://bugs.xxxxxxxxxx.de/’ was loaded over HTTPS, but requested an insecure stylesheet ‘http://bugs.xxxxxxxxxx.de/themes/CleanFS/theme.css‘. This request has been blocked; the content must be served over HTTPS.

Closed by  peterdd
03.08.2016 07:48
Reason for closing:  Not a bug
Additional comments about closing:  

but parameter should be documented

Project Manager

I have no experience with reverse proxies, but have you tried setting 'force_baseurl' in section 'general' of flyspray.conf.php for your case?

A part of the stuff that handles that baseurl is at start of includes/constants.inc.php

Alex commented on 02.08.2016 07:05

Nice, the force_baseurl option fixed my problem!
Maybe you want to add this to your documentation? ;)

Project Manager

Nice to hear.

Now I know for what scenario the force_baseurl it is for. :-)

Yes, should be documented.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing