Flyspray - The bug killer!

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Javascript
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 1.0-rc
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by Ioannis Protonotarios - 25.10.2016
Last edited by peterdd - 22.11.2016

FS#2226 - Popup calendar never worked for me (missing jscalendar language settings)

The first time I saw the popup calendar in action was in the present official site. In my installation never worked, neither in 0.9.9.7 that I used to have, nor in 1.0-rc1 that I have now. When I click on it it just goes to top of page.

Closed by  peterdd
22.11.2016 19:40
Reason for closing:  Complete
Project Manager
peterdd commented on 25.10.2016 17:35

Please upgrade first to Flyspray 1.0-rc3 or Flyspray github master. ( https://github.com/Flyspray/flyspray/archive/master.zip )

If the error with popup calendar still exists:

  • Which webbrowser/version?
  • Do you have the .htaccess working or not? ( see htaccess.dist which can be used as template for .htaccess file)
  • Does the browser webdeveloper tools show any javascript errors ( F12 opens web developer tools in most current web browsers)
Ioannis Protonotarios commented on 25.10.2016 20:45

I upgraded to master and the issue persists.

I don't think that it has to do with webbrowser (=latest FF dev) or .htaccess (=deleted) because I may have accidentally found what's causing it.

As I was playing around with web developer tools I noticed that there is a file loaded: calendar-el.js that is fully localized to Greek (el). I found that strange because this was another issue I was about to report: that the month names appeared in English in my Greek Flyspray. So it hit me! I changed the locale to en and boom! Calendar works perfect!

Moreover, when in Greek, I was unable to change short or long dates to other formats. But when in English I can.

Project Manager
peterdd commented on 25.10.2016 21:06

Confirmed on bugs.flyspray.org too when I switch to greek language.

javascript error is shown on console, see attachment. So lets review the js/jscalendar/lang/* files.

The language isn't the same as localization, but for now lets choose the settings for the majority of native greek speakers.

Project Manager
peterdd commented on 25.10.2016 21:27
Ioannis Protonotarios commented on 26.10.2016 01:10

done!

Works perfect now!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing