Flyspray - The bug killer!

  • Status New
  • Percent Complete
    0%
  • Task Type Information
  • Category Backend/Core
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Low
  • Reported Version 1.0 devel (github master)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by peterdd - 17.11.2016

FS#2313 - different composer.json for different php versions?

I still struggle with composer.json for doing Flyspray builds with included 3rd party libs for different PHP versions.

It is annoying composer.json is just an array, no comments, no conditionals
- and I’m still noob with composer and phpunit stuff.

Main source of problem: oauth2-client and guzzle breaking compatibility with PHP5.3 and PHP5.4

PHP5.3 oauth2-client 0.3 with additional patches (peterdd), guzzle 3.*
PHP5.4 oauth2-client 0.12.1, guzzlehttp ???
PHP5.5 oauth2-client 1.*, guzzlehttp >=6.2.1
PHP5.6 oauth2-client @stable, guzzlehttp >=6.2.1
PHP7 oauth2-client @stable, guzzlehttp >=6.2.1

Any suggestions how to solve this?

Do we really have to maintain different flyspray source trees just with different composer.json files???
Or backport auth2-client to PHP5.3 and PHP5.4 and use our versions in composer.json (no manpower for this)

Also the oauth2 stuff is not tested at the moment, so OAuth2 for Flyspay could be broken for some PHP versions.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing