Flyspray - The bug killer!

  • Status Closed
  • Percent Complete
    100%
  • Task Type Information
  • Category Backend/Core
  • Assigned To No-one
  • Operating System Linux
  • Severity Low
  • Priority Very Low
  • Reported Version 1.0-rc
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by Julia LECLERC - 08.03.2017
Last edited by peterdd - 24.03.2017

FS#2428 - Attachments

I can’t change logo I have the error message:

Warning: move_uploaded_file(./Logo_SIH - Copie.jpg): failed to open stream: Permission denied in /var/www/html/flyspray/includes/modify.inc.php on line 1269
Warning: move_uploaded_file(): Unable to move '/tmp/phpcjOFQh' to './Logo_SIH - Copie.jpg' in /var/www/html/flyspray/includes/modify.inc.php on line 1269

In addition, I haven’t the option to attach a file.

Please help me.

Thank you

Julia LECLERC

Closed by  peterdd
24.03.2017 20:43
Reason for closing:  Not a bug
Additional comments about closing:  

was probably selinux ACL related

Project Manager
peterdd commented on 08.03.2017 21:38

Could you please check the ownership (user and group) and permissions of Flyspray root (BASEDIR).

For example on one of my virtual server hostings it looks like this:

root@*** /var/www/html/ # ps aux |grep apache
www-data ....  /usr/sbin/apache2 -k start
...

root@*** /var/www/html/flyspray # uname -a
Linux Debian***

root@*** /var/www/html/flyspray # ls -la
drwxr-xr-x 16 www-data www-data    4096 Nov 16 21:42 .
drwxr-xr-x  6 www-data www-data    4096 Feb  6 18:39 ..
drwxr-xr-x  2 www-data www-data    4096 Oct  4 13:01 attachments
In addition, I haven’t the option to attach a file.

Do you mean when submitting a task or comment? Check if you have the 'create attachment' permission. ( see /index.php?do=myprofile or group permissions in flyspray admin area)

Julia LECLERC commented on 09.03.2017 16:07

I checked different permissions and I have full permissions on flyspray and on my database but the problem persits.

When I check ps aux | grep apache :
apache.. /usr/sbin/httpd - DFOREGROUND

In addition I haven't the button Attach a file when submitting a task and comment. However on the admin area I check the option but when I'm connecting with user and go to index.php?do=myprofil the option isn't configure. I don't understand why... Is there a line of a configuration file to modify or add?

Thanks for your help

Julia LECLERC commented on 20.03.2017 09:31

What's the option to activate attach a file on file.conf? What are files?
My problem isn't solved

Please help me, thank you

Project Manager
peterdd commented on 20.03.2017 19:37

I think your problem is not Flyspray, but the restrictive default settings of SELinux.

Maybe your server log files tell more about the root problem.

Probably you have to enable/set some permissions to allow Apache/PHP/Flyspray to handle uploads. Maybe also tweaking the Temp-directory settings where PHP temporarly stores files uploads until Flyspray put they where they are finally stored.

What is the output of

ls -laZ /var/www/html/flyspray

?

man ls
...
-Z, --context print any SELinux security context of each file
...

Maybe httpd_sys_rw_content_t selinux permission is what is needed.

Possible starting points:

https://wiki.centos.org/HowTos/SELinux

http://serverfault.com/questions/626610/selinux-preventing-apache-from-writing-to-a-file

or ask a search engine: 'selinux apache upload'

(I have no experience yet with SELinux.)

Julia LECLERC commented on 24.03.2017 08:46

You can close this task. I configured another server centos and it's ok. I have full option and I can attach files.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing