• Status Unconfirmed
  • Percent Complete
  • Task Type Bug Report
  • Category Backend/Core
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Low
  • Reported Version 1.0 devel (github master)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray
Opened by simpleshop - 29.10.2017
Last edited by peterdd - 29.12.2017

FS#2449 - Unexepted exception on smtp gmail send

On creating task we got error on event which must send e-mail via “google mail”.

I hoped that in rc6 this will be solved but not. This error was the same on rc4.

Another image.

Don't know why, but now it's working.
This was happening all the time also in RC4, and the same story is in RC6.
Sometimes it's working sometimes not.

But anyway, you should do that in case of problem bug tracker would not die but just make user friendly notice that e-mail was not sended.

Any news? Do you need some extra logs or something?

With this error bug tracker become completly unusable, every time on every change you need to go back after error apears and check if everything was posted OK.

And the biggest problem is that other users are not notified.

Will this be solved? Or we must find some bug tracker which can send e-mails correctly?

Project Manager

Hello Simple Shop,

logs and your current settings could be helpful to reproduce the problem.

I'm not familiar with email server things, so not dived into this yet.
I used always localhost at webhostings and gladly the rest handled the webhosters mail server for me.

Will try to reproduce and catch such exceptions, have more time in jan2018 than 2017.

Googling that error message shows possible reasons:

  • a firwall rule on your windowsserver (you use IIS as I see)
  • DNS problem (from a stackoverflow forum)
  • limits of gmail (send rate?) - maybe registering your server as valid sender at Google somewhere?
  • higher TLS, authentication types or other config requirements

As I'm not familiar with gmail, I do not know yet if this could help:
Search: Enable 'Less secure apps' within GMAIL

You wrote

Sometimes it's working sometimes not.

Could you find differences? Are the mail receivers differ? Or only at some Flyspray events?

Do you have the optional scheduler configured, that sends also notifications? On linux done by cronjob, on windows you can probably configure that with windows task planer.

Project Manager

Not the same problem, but just if someone stumble over this:

Tried to reproduce, but the web hosting where I tried with seems to block outgoing smtp. Probably they want every mail through their own mail local/mx server.

Connection could not be established with host [No route to host #113

At home local computer:

telnet 587
Connected to
Escape character is '^]'.

But on webhosting no success:

telnet 587
telnet: connect to address No route to host
telnet: connect to address No route to host
Trying 2a00:1450:400c:c04::6d...

My plan now in this order:

  1. Fix the FS_MAIL_LOGFILE feature that was deactivated years ago probably due incompatible with the newer 5.x swiftmailer versions. done. github master
  2. I try to catch mail error messages better by Flyspray than currently.
  3. Will try to reproduce your problem with my other servers ..

Thank you.

Must say that we did not change anything regarding web server and network.
So something stopped working from nowhere?

But I know that other web services works OK - used on Joomla and Wordpress.., same PHP version...


Available keyboard shortcuts


Task Details

Task Editing