Flyspray - The bug killer!

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend/Core
  • Assigned To No-one
  • Operating System Linux
  • Severity Medium
  • Priority Very Low
  • Reported Version 1.0-rc6
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by Simon Byholm - 12.02.2018
Last edited by peterdd - 16.07.2018

FS#2457 - Class 'HTMLPurifier_Config' not found in /srv/http/flyspray/includes/modify.inc.php on line 423

I just upgraded from Flyspray 1.0-rc1 to Flyspray 1.0-rc6 and now when I try to move a task from one project to another I get this error.

I upgraded according to the instructions, by deleting all files except the few mentioned and copying the new flyspray into the folder.

Then I clicked no in setup for whatever conversion was suggested, related to DocuWiki.

Closed by  peterdd
16.07.2018 16:38
Reason for closing:  Not a bug
Additional comments about closing:  

was incomplete install from source

Simon Byholm commented on 12.02.2018 11:21

I did a print_r before the error and apparently I have
[syntax_plugin] ⇒ none
Which is also the value in the config file

Project Manager
peterdd commented on 12.02.2018 11:40

Old composer.lock in flyspray root directory? Remove and try

php composer.phar install

HTMLpurifier added with 1.0-rc4, so running composer with current composer.json required.

Project Manager
peterdd commented on 12.02.2018 11:43

HTMLpurifier is used for 'none', '', and 'html'.

Only when syntax_plugin='dokuwiki' the HTMLpurifier is not used, because dokuwiki handles the filtering/rendering by itself.

Simon Byholm commented on 12.02.2018 12:57

The composer thing is the problem I guess, I don't have it on our system, and there was no mention of it anywhere. I ended up fixing the problem by manually downloading the htmlpurifier and adding:

require_once BASEDIR . '/htmlpurifier/HTMLPurifier.auto.php';

to headers.php

Probablay better to get composer intalled to not break the next Flyspray upgrade.

Would be a good idea in the upgrade guide, on the download page, to mention dependencies to install before upgrading

http://www.flyspray.org/docs/download/

Maybe there's more dependencies I will get errors from later?

Another idea for the setup script to check the dependencies and give some info on where to get and how to install

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing