Flyspray - The bug killer!

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Information
  • Category Backend/Core
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 1.0-rc7
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by Lucas K - 10.08.2018

FS#2476 - Guzzle/Guzzle is abandoned, should use library that's still being developed

(Working on a network monitoring system that really needs a ticketing system, saw this and since I speak PHP, thought it would be a good place to start... I just installed and am sharing my notes, do with them what you will!)

Project Manager
peterdd commented on 10.08.2018 11:30

Guzzle is a dependency automatically resolved by composer, coming from using an older 0.12.1 of oauth2-client in composer.json

Newer versions of oauth2-clients seem to use guzzlehttp, but oauth2-client 1.0 and newer support only newer PHPversions and also has API breaks. And noone has yet tried what exactly must be changed when using a current version of oauth2-client for Flyspray.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing