Flyspray - The bug killer!

  • Status New
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Backend/Core
  • Assigned To
    peterdd
  • Operating System All
  • Severity Low
  • Priority Low
  • Reported Version 1.0-rc9
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by peterdd - 29.07.2019
Last edited by peterdd - 29.07.2019

FS#2559 - a duplicate close accepted even when missing comment/ referencing other FS# task

Closing a task with selected close reason duplicate should warn when there is no comment or FS # id is given in the close comment text field.

The task is closed as duplicate without any further notice. The information to which task it is duplicate or a description (if the problem is logged/handled outside Flyspray) is lost.

Possible solutions

Frontend hints

  • variant F1 (soft): When duplicate as close reason is selected, a placeholder attribute in the close comment text field could be shown/updated. (maybe as ‘css only’ possible)
  • variant F2 (harder): Deny sending the form if duplicate selected, but comment text field is empty. and shows warning info. (javascript required, nojs browsers still send form.)
  • variant F3 (hard): Deny sending the form if duplicate selected and no task id detected in comment text field. and shows warning info. (javascript required)

Backend deny

  • variant B1 (soft): When request wants close a task with duplicate reason and (cleaned) comment string is empty, deny closing the task and give feedback to user why it was denied.
  • variant B2 (hard): It requires detecting a task id in the comment field and the first detected task id is taken for referencing as ‘is duplicate of’. Limitation of this is that the duplicate could be also a ticket or something of a complete other system.
This task has the following sub-task
ID Project Summary Priority Severity Assigned To Progress
2560 Flyspray - The bug killer! FS#2560 - do not allow close task with reason duplicate referencing to its Low Low peterdd
0%

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing