Flyspray

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Backend/Core
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version 1.0 devel (github master)
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray
Opened by Neustradamus - 25.09.2020
Last edited by peterdd - 04.04.2021

FS#2616 - There is a problem after a http/https link on a line without text after, at the end of the sentence

When we add http/https links there is a problem.

I think, the problem is here for other URI too.

Examples:

1/ With this code without code section :
The code:

blablabla
- https://example.tld
- https://example.tld

We obtain:

The code :
blablabla
- https://example.tld - https://example.tld

2/ Same to with a text in more, with this code without code section :
The code:

blablabla
- example 1 https://example.tld/
- example 2 https://example.tld/

We obtain:

The code :
blablabla
- example 1 https://example.tld/ - example 2 https://example.tld/

Closed by  peterdd
04.04.2021 04:24
Reason for closing:  Not a bug
Additional comments about closing:  

see also https://www.dokuwiki.org/ wiki:syntax

Same problem for an internal link:

Text before the new line
- "FS#2616 - There is a problem after a http/https link on a line without text after, at the end of the sentence"
Text after on a new line

We obtain:

Text before the new line
- " FS#2616  - There is a problem after a http/https link on a line without text after, at the end of the sentence"
Text after on a new line

Task Type of this ticket must be "Bug Report".

Project Manager

Yeah, somewhere a break stripped off.

But the syntax for ordered list is

  - ordered list item 1
  - ordered list item 2

in dokuwiki

not

- ordered list item 1
- ordered list item 2

https://www.dokuwiki.org/wiki:syntax#lists

Thanks for your comment, but I do not want syntax for ordered list, I want only a solution to the bug :)

There is another bug, there is only one line and 16 x 123456789 with one space between.

123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789

We obtain:
123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789

The text is cutted… (already in my first comment here: https://bugs.flyspray.org/index.php?do=details&task_id=2616#comment5774

There is another example too without http/https link but with "":

Text before the new line
"0"
Text after on a new line

We obtain:

Text before the new line
"0"
Text after on a new line

There is a bug in previous comment:

There is another example too without http/https link but with "":

Text before the new line
"0"
Text after on a new line

We obtain:

Text before the new line
"0"
Text after on a new line

Ah!!

This bug is only in preview!


There is a bug in previous comment:

There is another example too without http/https link but with "":

Text before the new line
"0"
Text after on a new line

We obtain in preview:

Text before the new line
"0" Text after on a new line

Another bug:

A link for example with a last "-" is not complete:
- https://domain.tld/this-is-a-test-link-

Another bug:

Bad link with ():

- https://domain.tld/example(p=example.5)

Preview:

Bad link with ():
- https://domain.tld/example(p=example.5)

Project Manager

@Neustradamus

I think these are not bugs:

The task main issue

blablabla
- https://example.tld
- https://example.tld

is just recognized as one paragraph. The added break after blablabla maybe is just convenience done by dokuwiki, or a really little bug.

blablabla
- https://example.tld - https://example.tld

Even

blablabla

- https://example.tld
- https://example.tld

The two links are recognized as one paragraph, so appear on one line.

What you wanted is

blablabla

  - https://example.tld
  - https://example.tld

blablabla

https://www.dokuwiki.org/wiki:syntax

For the '16 x 123456789' example:

This is also not a bug, I added

#taskdetailsfull p, #taskdetailsfull li, .commenttext p, .commenttext li {
    max-width: 40em;
}
 
.links a, #taskdetailstext, #taskdetailsfull h2, .commenttext {
    word-wrap: break-word;
    word-wrap: anywhere;
}

to wrap overlong lines for better readability.

The '"0"' example: Well, it should be all on one line as there is no empty line between them.

Text before the new line "0" Text after on a new line

The link with - at end:
The automatic/heuristic link detection is a convenience of dokuwiki.
If you really want a complete link use the

[[linkaddress]]

format.

Also for the last:

- https://domain.tld/example(p=example.5)

- https://domain.tld/example(p=example.5)

- [[https://domain.tld/example(p=example.5)]]

- https://domain.tld/example(p=example.5)

What I see is a requirement for a quick help/cheatsheet within the dokuwiki editor so people get the syntax right while writing. I started that a while ago but never got that ready to activate it.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing