Flyspray - The bug killer!

  • Status Closed
  • Percent Complete
    100%
  • Task Type Feature Request
  • Category User Interface
  • Assigned To
    Florian Schmitz
  • Operating System All
  • Severity Low
  • Priority Defer
  • Reported Version 0.9.5
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by Phil - 07.06.2004
Last edited by Anonymous Submitter - 27.11.2004

FS#276 - Search for all active tasks

When filtering tasks it would be nice if a developer could quickly search for all open tasks that can receive immeditate attention.

Not all status values can be actively worked on by a developer. As a developer, I probably will only do something about "assigned", "new" and "reopened" tasks. Only occassionally will I need to see "requires testing" items or "waiting for customers", etc... but I always need to see "assigned", "new" and "reopened" tasks because these
are the items that typically need immediate attention.

It would be great if either a custom filter could be defined -or- simply a filter specific to including only these 3 status types. There are already "All Statuses" and "All Open Tasks" so adding "All assigned, new, reopened" (or similar) would be quite useful.

Keep up the great work!

Closed by  Florian Schmitz
15.01.2006 09:32
Reason for closing:  Will Not Implement
Additional comments about closing:  

instead the my last search functionality will be extended

Mac Newbold commented on 27.05.2005 20:49

Seems like a handy feature. Doesn’t sound hard either. But what would the drop down menu call it? “Active tasks”? Or something else?

Phil commented on 27.05.2005 20:56

How about “All Active Tasks”? That would suffice I suppose.

Anonymous Submitter commented on 27.05.2005 23:18

This could be hard to implement if we also do  FS#287 . If the status list becomes editable through the web interface, then we won’t be able to hard-code which statuses are considered “active”.

Mac Newbold commented on 28.05.2005 00:26

It might work well to do it similarly to the version lists, where the user gets to categorize them. For example, a version might be past, present, or future, and the “due in” list gets future ones, and the past/present ones go in the “reported version”. To me, this is a similar thing. We let the users edit the list of statuses, and give them checkboxes for whether or not that status is an “open” status, and whether or not that status is an “active” status. Actually, it’s probably radio buttons: every status is either a closed status, an open status, or an active (and open) status. Maybe one more option is required for something like unconfirmed, but I think that would about cover it.

Nathan commented on 08.07.2005 03:30

My advanced search patch will solve this since it allows for multiple selection of statuses.

Mac Newbold commented on 23.12.2005 19:06

What’s the status on this? I think it ought to be marked for 0.9.9, especially since the advanced search feature is also done now.

Regarding the  FS#287  interaction: The items in the list just need to specify whether they are active/open statuses or not, similar to the versions specifying whether they are past/present/future.

Admin
Florian Schmitz commented on 14.01.2006 18:12

The more I think about this task the less I like it. For example I see a problem with “giving statuses statuses”: A status may be open or active...but why should open and active be contradictory? We also can’t add a “closed” status because there is only one possible status for closed tasks. The whole thing adds unecessary complexity.

I suggest that everyone selects the statuses he thinks are “active” in the new multiselect and that’s it. We could then add a feature which makes it possible to store multiple searches (so everyone can save his own search for “active” tasks) which is of much more use for everyone. Thoughts?

Mac Newbold commented on 14.01.2006 19:20

That could work I guess. I wasn’t suggesting that “open” or “active” had to be mutually exclusive or contradictory. For example, I would set Pending, New, Assigned, Reopened as Active and Open, and set Waiting for Customer as Open, but not Active, and Researching and Requires Testing could go either way, though I’d tend to lean toward not active. I like the idea of saving searches, though. I could see having a list of saved searches that I had assigned names to and would be able to choose from a dropdown, but I can also see having every search automatically get saved to a list of recent searches, without a name (though maybe an autogenerated description of the parameters?) that I could also choose from a dropdown. One related thing I would like to see would be to make it easy to run the same search on several different projects, with each result set including only tasks from a single project. I think right now the show tasks button up by the project selector clears out any advanced search parameters. That brings us to the question of whether the current project selection, and the all tasks/assigned to me/tasks I’m watching/tasks I opened selector, should be saved with the search, or be independent from it, or be an option you can choose when you save your search.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing