Flyspray - The bug killer!

  • Status Closed
  • Percent Complete
    100%
  • Task Type Feature Request
  • Category User Interface
  • Assigned To
    Florian Schmitz
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 0.9.4
  • Due in Version deprecated 1.0.0
  • Due Date Undecided
  • Votes 5
  • Private
Attached to Project: Flyspray - The bug killer!
Opened by Anonymous Submitter - 20.07.2003
Last edited by Florian Schmitz - 24.04.2007

FS#44 - Changelog generator

Create a "Reports" page that allows an admin to generate all sorts of statistics about tasks. These include, but are not limited to:

Changelog generation (since specified date)
Due for next release (open, closed and all)
Tasks closed since specified date

etc etc

Closed by  Florian Schmitz
24.04.2007 20:29
Reason for closing:  Implemented in devel
Additional comments about closing:  

rev 1170

Anonymous Submitter commented on 12.08.2003 12:44

The first report to generate is a list of tasks closed between two dates. The user should be given the option to sort asc or desc. I promise to start work on reports after releasing Flyspray 0.9.4 :-)

That’s a good idea to start with
a joke
what I personally would
would like to have statistics for every project
Also a difference between the different Task Types would be nice. I don’t need all Bugs & Feature requests mixed together.

Ohhh.... is would also be nice to have a script to include them into the homepage as well, if this is not a problem of course and you have much time ;-)

Anonymous Submitter commented on 22.01.2004 04:11

Sorry, but I’ve just pushed this back another release. I hope to start work on a system log for every event, and any proposed reporting would be able to pull from the log after that.

My boss (or rather HIS boss) asked if it could track time spent on a job.

I’d guess this would require the developers to enter time spent when updating the status of a task, and for this data to be added to the log you’re talking about generating, then a reporting program could total time spent by each developer, yada yada.

me, I think stuff like that is BS but if it keeps the bosses busy and out of our hair, more power to it...

sirex commented on 15.05.2004 11:12

that does indeed sound like a typical manager style waste of time. :-)

ironic, really.

Anonymous Submitter commented on 04.06.2004 12:40

Patrick has submitted a patch that implements  FS#91  - the system log I referred to above. You can see it in action by clicking the new History tab. We will use the data displayed on the History tab for reports.

I’ve got the infrastructure for this largely done now. I’ve created a reports.php script which is linked from the menu, and contains tabs (so far) for:

*


Age

I’ve also created a new language file for it, English-only so far. Right now the Summary report does nothing, the Changelog report generates a changelog containing all task closures between two dates (which are selectable using a pop-up date selector), the Severity report lists a count of each severity, and the Age report does nothing.

So it’s well on the way, just got to add some more specific functionality within some of the report types.

Assorted new files and patches for the basic report infrastructure

   reportsstuff.tar.gz (10.6 KiB)
Anonymous Submitter commented on 24.08.2004 14:13

I made some small changes to Jon’s attached files, and committed it to svn. You can see how it looks on this very site. Simply select “Reports” from the menu at the top of the page.

Hi Tony, I think there’s something wrong with the date format processing. I’ll sync the changes you made back to my local copy (looks good, BTW!). I’ve also got to merge in Patrick’s event report stuff.

pie graph with fixes for jpgraphpath setting

   reports-graph-pie.php.diff (1.2 KiB)

Hi Tony, as we were discussing last night the problem with the pie charts was definitely the path to JpGraph. I’ve attached a patch (well, the patch actually generates the whole file!) which unfortunately has to parse the config file locally since this script is referenced as an image and not included in the main script. It therefore doesn’t have access to any variables other than what we pass it.

Anonymous Submitter commented on 12.09.2004 07:02

I don’t want the users having to edit any file besides flyspray.conf.php (and header.php if they move the conf file). Isn’t there any other way to use this without statically defining the config path in the script?

I was happily checking out the reports which are looks great, but I did hit upon a few issues with the Event Report:sort by task Id with date as a secondary sort would be great), also the task ID column has no
clicking on the column title “Date” gives me a page with “- Do request is
clicking on the column title “User” gives me a page with “Order request is
Can not sort by the column “Summary”, probably not a big
clicking on the column title “Event” gives me a page with “- Do request is
very minor thing, if the result of the filter is nothing (did this by setting the start date after the end date), the user is given the following statement “No history for this task available.”. This is not really correct, maybe “No events could be found for tasks matching the given
that helps, keep up the great

Can I ask if the following two items would be possible at some time in the future during the development of reports.

1. Would it be possible to select what columns appear for each report, like you can on the tasks lists screen.

2. Would it be possible to group tasks under section headings for something like a Known Issues Report.

It could mean being able to link a resolution to a section as it would be nice to segregate the report into sections:

Section                Flyspray Resolution
========               ===================

Open Tasks             NEW
  e.g. Task ID, Task Type, Category, Severity, Summary, Due In
Deferred Tasks         DEFERRED
Pending Tasks          PENDING
Fixed Tasks            FIXED, IMPLEMENTED
Closed Tasks           NOT A BUG, WON'T FIX, , WON'T IMPLEMENT, 
                       WORKS FOR ME, DUPLICATE, CLOSED

What do users think? I just thought I’d brainstorm the idea. Thanks.

Sorry Bevis, maybe I’m being thick this morning but I don’t quite follow what you’re asking for with #2. Do you mean display all items that have been closed, grouped under headings based on the “close reason” value?

Jonathan, I think you’ve summed up what I was trying to say in once sentence. Yes a grouping feature for defects in a report would be great.

Sorry I wasn trying to give an example to avoid saying “it should be designed this way blah blah...”

Sorry to sneek another feature request in but .... ( I just can’t help myself can I)

Would the feature be able to produce reports in PDF format, if a user wishes, I’m not suggesting writing a PDF creation module but rather implementing something like http://sourceforge.net/projects/pdf-php if that’s easier. I have assumed that they are currently a HTML page.

Anonymous Submitter commented on 17.02.2005 09:38

That php class very impressive. I vote that we do use it somehow in the reports area.

Anonymous Submitter commented on 28.01.2006 12:51

Votes Report is pretty much done. It generates a basic report about the tasks that users have voted for, with ajax and all.

Can you please included the css’s for each page into the printing? I can not print out a report of the bugs atm because it looks horrific.

Admin

Print-CSS is already included. Why doesn’t it work for you?

Anonymous Submitter commented on 19.02.2006 07:37

This task can stay open indefinately, as we can always add more reports.

Just tried to download the reportsstuff.tar.gz file but it does not open in WinRAR, the app says the file is corrupt. Has anyone else had a problem with this. I was hoping to take a look at some of the new reports.

Is it the plan to release all the reports listed in reports.php (events, changelog, severity, age) in the next stable

Interesting report (for me): ranking of people who reported/resolved the greatest number of tasks :)

I’d like to see a milestone report - similar to what is Trac (example: http://projects.edgewall.com/trac/roadmap) using.

It should display all future milestones (”due in version” in Flyspray), each headed with a progress bar displaying open versus closed tasks due in that particular version, followed by a list of opened and/or closed tasks (selectable).

I can do similar things already by sorting the main task list by “due in version” - bit I am missing such a fancy progress bar summarizing all opened/closed task due in that version.

*swoosh* Silly me... Guess what happened when I clicked the “Roadmap” link in the web pages header... ;-)

I feel stupid, but with Flyspray 0.9.9.beta2, I can not find any reports beyond filtered task lists. One of the comments here refers to the “reports area”, “Votes Report”, etc. but even though I’m logged in as an admin, I can find no such options. The user manual has no information about reports either.

Admin

Reports do not exist since 0.9.9 anymore (because the functionality of the task list has been vastly extended). However, a changelog generator would still be a good think to have. Thus I’ll change the task so that it will be closed once this particular feature is done.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing